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MODULE 5: THE DEVELOPMENT ENVIRONMENT 

Module Overview 
In the module, Microsoft Dynamics® NAV Server, you were introduced to the basic 
functionality of the Development Environment. The Development environment 
acts as a client and is important for all Microsoft Dynamics NAV 2013 
deployments as a tool for development and administration tasks. This module 
describes how to install and use the Development Environment.  

Objectives 

The objectives are:  

• Install the Development environment. 

• Explain how to manage databases, companies, licenses and objects. 

• Explain the possibilities of the Demo License.  

• Explain how to upload a Microsoft Dynamics NAV license. 

• Explain the functionalities of the Object Designer. 
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Installation 
The Development environment acts as a client and is important for all Microsoft 
Dynamics NAV 2013 deployments as a tool for development and administration 
tasks. For example, you must use it to upload the Microsoft Dynamics NAV 2013 
license file.  

Install the Development Environment 

You use Microsoft Dynamics NAV Setup to install the Development Environment. 
The Development Environment is a subcomponent of the client.  

The Development Environment is installed automatically when you select the 
Install Demo or the Developer option. It can also be added as part of the Client or 
the Custom installation option. 

You can install the RoleTailored client for Windows without the Development 
Environment, but you cannot install the Development Environment without the 
RoleTailored client for Windows.  

Demonstration:  Install the Development Environment 
Using the Client Installation Option 

The following demonstration shows how to install the Development Environment 
on a computer without any other Microsoft Dynamics NAV component. In this 
demonstration, we select the Client installation option and customize it (that is, we 
add the Development Environment component manually).  

Demonstration Steps 

1. Insert the Microsoft Dynamics NAV 2013 product DVD in the DVD 
drive. 
a. Open the DVD drive by pressing the Eject button on the physical 

drive. 

b. Put the DVD on the tray. 
c. Press the Close button to close the DVD drive. 

 
2. Start Microsoft Dynamics NAV Setup. 

a. Open Windows Explorer. 
b. Select Computer to see a list of available drives. 
c. Select the DVD drive that contains the product DVD.  

d. In the root folder of the selected drive, double-click setup.exe. 
e. If you receive the Open File - Security Warning “Do you want to 

run the setup.exe application?” message, click Run. 
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3. Select the installation option. 
a. In the Welcome to the Microsoft Dynamics NAV 2013 Setup 

window, click Next. 
b. On the Microsoft Software License Terms page, click I Accept.  
c. On the Microsoft Dynamics NAV Setup page, select Click an 

Installation Option. 
 

4. Specify parameters. 
a. On the Choose an installation option page, click the Customize 

link for the Client option. 

b. On the Customize the installation page, click the icon at the left 
of the Client node. The node expands. 

c. Click the icon at the left of the Development Environment 
(C/SIDE) node. 

d. Select Run from My Computer. 
e. Click the icon at the left of the Documentation node. 
f. Select Not Available. 
g. On the Customize the installation page, click Next. 
h. On the Specify parameters page, in the Server Name field, 

enter the name of the server that is running the Microsoft 
Dynamics NAV Server instance to which you want to connect.  

i. In the Service Name field, enter the name of the server instance 
to which you want to connect.   

j. In the Client Services Port field, enter the port number that the 
server instance is using for its client services. The default value is 
7046. 

k. Verify that the Add rule to Firewall field is set to Yes. 
l. Click Apply to start the installation.   
m. Click Close to exit Microsoft Dynamics NAV Setup. 

Add a Development Environment 

To add a Development Environment to a computer that is already running some 
other Microsoft Dynamics NAV components, run Microsoft Dynamics NAV Setup 
on the computer where you want to install the Development Environment.  

Unlike the RoleTailored client, the Development Environment does not connect to 
the Microsoft Dynamics NAV database through Microsoft Dynamics NAV Server.  
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Demonstration:  Add the Development Environment to an 
Existing Deployment 

This demonstration shows how to add the Development Environment to a 
computer that is already running other Microsoft Dynamics NAV components. 
When you start Microsoft Dynamics NAV Setup, it opens in Maintenance mode.  

Demonstration Steps 

1. Insert the Microsoft Dynamics NAV 2013 Product DVD in the DVD 
drive. 

a. Open the DVD drive by pressing the Eject button on the physical 
drive. 

b. Put the DVD on the tray. 
c. Press the Close button to close the DVD drive. 

 
2. Start Microsoft Dynamics NAV Setup. 

a. Open Windows Explorer. 

b. Select Computer to see a list of available drives.  
c. Select the DVD drive that contains the product DVD.  
d. In the root folder of the selected drive, double-click setup.exe.  
e. If you receive the Open File - Security Warning “Do you want to 

run the setup.exe application?” message, click Run.  
 

3. Select the installation option. 
a. In the Welcome to the Microsoft Dynamics NAV 2013 Setup 

window, on the Maintenance page, click Add or remove 
components. 
 

4. Specify parameters.  

a. On the Customize the installation page, click the icon at the left 
of the Client node. The node expands. 

b. Click the icon at the left of the Development Environment 
(C/SIDE) node. 

c. Select Run from My Computer. 
d. On the Customize the installation page, click Next. 
e. On the Specify parameters page, click Apply to start the 

installation.   
f. Click Close to exit Microsoft Dynamics NAV Setup. 
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Run the Development Environment 

After you have installed the Development Environment, you can run it by 
selecting Start > All Programs > Microsoft Dynamics NAV 2013 Development 
Environment.  

The first time that you open the Development Environment, it is not connected to 
a Microsoft Dynamics NAV database.  

 

FIGURE 5.1: THE DEVELOPMENT ENVIRONMENT WINDOW ON FIRST USE 
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When you open a database, the Development Environment opens the Object 
Designer window. The name of the database appears in the application title bar. 

 

FIGURE 5.2: DEVELOPMENT ENVIRONMENT THE DEVELOPMENT ENVIRONMENT CONNECTED 
TO THE NAV_DEMO2013_LIVE DATABASE 

When you reopen Microsoft Dynamics NAV 2013, the program automatically 
opens the database and company on which you last worked.  

    Note: The name of the database and the company that you were last working 
on is stored in the *.zup file. You can find this file in the c:\users\<user 
name>\AppData\Roaming\ folder. If you delete this file, Microsoft Dynamics NAV 
opens, but does not establish a connection to a Microsoft Dynamics NAV database.  

The Development environment can be used to do the following:  

• Manage databases 

• Manage companies 

• Manage Microsoft Dynamics NAV licenses 

• Manage Microsoft Dynamics NAV objects 
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Unlike the RoleTailored client, the Development environment does not connect to 
the Microsoft Dynamics NAV database by using a Microsoft Dynamics NAV Server 
instance.  

    Note: You can click Tools > Language to change the language of the user 
interface. Please be aware that some functionality is available only in English. This 
especially applies to the design and programming features. 

Managing Databases 
You can use the Development Environment to manage Microsoft Dynamic NAV 
databases. 

Open a Database 

To open a Microsoft Dynamics NAV database in the Development environment, 
click File > Database > Open.  

In the Open Database dialog box, you can select the database to open: 

 

FIGURE 5.3: OPENING A MICROSOFT DYNAMICS NAV IN THE 
DEVELOPMENT ENVIRONMENT 
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To select and open a database, you fill in the fields as follows: 

Tab/Field Description 

General / Server Name Enter the name of the SQL Server that 
runs the database that you want to open. 
You can click the  field and select the 
server from a list of available computers 
that are running SQL Server or you can 
enter the server name manually. 

General / Database Name Enter the name of the database that you 
want to open. You can enter the name 
manually, or you can click the field to 
make a selection from the list of 
databases that are available on the 
selected server. 

To retrieve a list of available databases 
from the selected SQL Server, you must 
first enter valid credentials. 

General / Authentication Enter the type of authentication that you 
require. Click the field to choose between 
Database Server Authentication and 
Windows Authentication. 

If you select Database Server 
Authentication, your authentication is 
performed by the SQL Server that you 
have selected. (You must provide a User 
ID and a Password.) 

    Note: To use database 
authentication, the Server authentication 
property for SQL Server must be set to 
SQL Server and Windows Authentication 
(Mixed mode). 
 
Database authentication can only be 
used in the Development Environment, 
not in the RoleTailored client for 
Windows. 

If you select Windows Authentication, 
your authentication is performed by the 
Windows domain controller. (You cannot 
provide a User ID and a Password.) 
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Tab/Field Description 

General / User ID Enter your User ID if you have selected 
Database Server Authentication. 

General / Password Enter your Password if you have selected 
Database Server Authentication. 

Advanced / Net Type Select the network type to be used when 
you connect to the server. The default 
value in this field is Default, which refers 
to the default client network type 
assigned by SQL Server.  (You can change 
the SQL Server default net type with the 
Client Network Utility, which is part of 
the SQL Server Client Utilities, if they are 
installed on the client computer.) 

Although you can change the default 
value, it is frequently not necessary to 
change the network type from the 
default setting.  

Advanced / Attach File Name If you want to attach and open a 
detached database that consists of a 
single data file (excluding the transaction 
log file), you must enter the full path and 
file name of the database in the Attach 
File field. This file typically has the .mdf 
extension.  
You can give this single file database any 
name by entering it in the Database 
Name field on the General tab.  

If no transaction log file exists alongside 
the data file, it is created automatically 
when you attach the data file. The 
database file is attached when you open 
it. 

After you have completed the fields in the Open Database window, click OK to 
open the database. 

    Note: To work in the application, you must always open a database and a 
company - in that order. After you have done this one time, or if the choices are on 
the command line that starts the program, this occurs automatically when you 
choose a company. Therefore, you only have to click File > Database > Open 
when you want to open a database different than the one currently open. 
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Close a Database 

If you have to close the database, you can do this by clicking File > Database > 
Close. You can use this function to close an open database, for example, before 
you open another database. However, you do not have to use it because the 
program saves all the data and closes everything correctly when you choose to 
open another database or exit the program. 

Delete a Database 

You can use the Development Environment to delete an existing Microsoft 
Dynamics NAV database. To do this, start the Development Environment and 
open the database that you want to delete. Next, click File > Database > Delete.  
Microsoft Dynamics NAV 2013 prompts you to confirm the deletion two times 
before actually deleting the database.  

    Note: Before you delete a database, verify that there are no active users in 
the database. In addition, stop all services and server instances that use the 
database that you want to delete.  

When you delete a database, all content of the database disappear. If it is 
necessary, make a backup of the database before you delete it.  

After you have deleted a database, the connection with the server is closed. You 
have to reconnect to a server and reopen a database if you want to continue 
working. 
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Create a Database 

The Development Environment can be used to create Microsoft Dynamics NAV 
databases on the computer that runs SQL Server. To do this, start the 
Development Environment, and then click File > Database > New. Before you 
can create a database, you must first specify the instance of SQL Server for the 
database and the authentication type:  

 

FIGURE 5.4: SELECTING THE INSTANCE OF SQL SERVER FOR A NEW 
DATABASE 

When you click OK, Microsoft Dynamics NAV tries to establish a connection to the 
selected SQL Server that uses the credentials specified.  

If a connection can be made, the New Database window appears: 

 

FIGURE 5.5: THE NEW DATABASE WINDOW 

In the New Database window, you must enter the information about the 
database that you want to create. The window contains the same Tabs as the 
Alter Database window. The tabs are as follows: 
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General 

On the General tab, you can define the logical name of the Microsoft Dynamics 
NAV database in the Database Name field. The tab also shows the server name. 
The value of the Server Name field is taken from the Select Server dialog box. 

Database Files 

The Database Files tab lets you increase the size of the database. You can do this 
as follows: 

• By increasing the size of one or more of the files that make up the 
database. 

• By adding new data files to the database. 

For more information about how to add new database files, see “How-to: Add 
New Database Files” in the online Help. For more information about increasing 
the size of a database file, see “How-to: Increase the Size of Database Files” in the 
online Help.  

By default, when you create a new Microsoft Dynamic NAV database, two data 
files are created. You can increase the size of each data file or add new data files 
to expand the database. If secondary data files are present, you only have to 
increase the size of the primary data file when the catalog that it contains has 
become too large. When the catalog has become too large, new SQL Server 
objects, such as tables, cannot be created until you increase the size of the 
primary data file. 

When you are using secondary data files, you cannot create more space for 
storing Microsoft Dynamics NAV data by increasing the size of the primary data 
file. You can create more space for storing data by increasing the size of the 
secondary data files that contain Microsoft Dynamics NAV information. You can 
also add new secondary data files to store more data. 

    Note: You can always make the database larger later, but you cannot make it 
smaller using the Microsoft Dynamics NAV Development Environment.  

If you have to reduce the size of the database, you can shrink the database files by 
using SQL Server Management Studio.  
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Transaction Log Files 

On the Transaction Log Files tab, you can increase the size of the existing 
transaction log files or add new log files to allow the database to perform more 
transactions. The transaction log continues to grow as new transactions are 
performed in the database. SQL Server truncates the log after it performs a 
successful database or transaction log backup (or after it commits a transaction in 
cases where the database recovery model is Simple). 

You can also delete existing transaction log files that are empty. The first 
transaction log file that is listed is the primary file. The primary transaction log file 
cannot be deleted. 

For more information about how to add new transaction log files, see “How-to: 
Add New Transaction Log Files” in the online Help. For more information about 
how to increase the size of a transaction log file, see “How-to: Increase the Size of 
Transaction Log Files” in the online Help.  

Collation 

You can also change the collation that is used by the database. You must set the 
database Single user option before you change the collation. For example, you 
might change the collation of a database when you plan to centralize multiple 
SQL Server databases (coming from different regions) on a single instance of SQL 
Server.  

A collation specifies the bit patterns that represent each character in a dataset. 
Collations also determine the rules that sort and compare data. Characteristics of a 
collation include, for example, accent sensitivity and case sensitivity.  

If you change the database collation, this changes the collation of all the objects 
in the database except tables that have the LinkedObject property set to Yes. 
These objects must be recreated manually by, for example, scripting them in SQL 
Server Management Studio. 

If you change the collation from a case-sensitive to a case-insensitive collation or 
from an accent-sensitive to an accent-insensitive collation, duplicates can occur in 
the primary keys of the tables. Duplicates can be caused by the values of the 
character data that is stored in the primary keys. If duplicates occur, you receive 
an error message and the alteration of the database collation is aborted. 
Therefore, we recommend that you do not change these attributes of a collation. 
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    Note: Changing the collation can be a lengthy process, depending on the size 
of the database and the number of companies in the database, because the system 
tables and all the user table indexes that contain character data must be rebuilt. 

You can restore a database by using a collation that is incompatible with the 
current database collation. When this happens, extended characters in data are 
displayed incorrectly. 

Options  

On the Options tab, you can define the database access mode and the recovery 
model for the database. The Single User option lets you restrict the number of 
users who can access the database. You must select this option, for example, 
before performing any database tests. (After the tests are complete, you must 
clear this option.) You can also define the recovery model of the database. This 
setting determines the kind of information that is written to the transaction log 
and therefore the kind of recovery model that you want to use in this database. 

For more information about the settings on this tab, see “Altering Databases – 
Options tab” in the online Help. 

Integration 

The Integration tab contains database settings that influence the way Microsoft 
Dynamics NAV 2013 integrates with SQL Server and external tools. 

For more information about the settings on this tab, see “Altering Databases – 
Integration tab” in the online Help. 

Advanced 

Use the Advanced tab to control the way locking is handled in the database, and 
to specify the UidOffset. 

For more information about the settings on this tab, see “Altering Databases – 
Advanced Tab” in the online Help. 
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Alter a Database 

When you create a database, you have to specify several settings for the new 
database. As soon as you have created the database, you can use the 
Development Environment to change the settings. To change the settings of a 
database, start the Development Environment and then click File > Database > 
Alter.  

 

FIGURE 5.6: THE ALTER DATABASE WINDOW 

In the Alter Database window, you can modify all settings of a database (except 
for the Server Name and Database Name fields). Please be aware that you have 
to activate the Single User option to change some fields.  

After you have changed the fields, click OK to close the Alter Database window 
and apply the new settings.  

Create and Restore Backup 

After you have created a new (and empty) database, you can enter program 
objects and company data. Before you can create company data, you must import 
some basic data from a backup copy of the original standard database. This is the 
demonstration database that is included with the application. The backup must at 
least include the parts called Data Common to All Companies and Application 
Objects. Data common to all companies includes the program's report list and 
permission groups. When you restore the application objects, the accounting 
application is transferred to the database. 

Microsoft Dynamics NAV has a built-in backup function that lets you create and 
restore a backup of a Microsoft Dynamics NAV database.  
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A database backup can consist of: 

• Entire Database (including all companies in the database, data 
common to all companies, and application objects). 

• All Companies (including data common to all companies). 

• Custom (whatever you select). 

After you have imported the application objects and the data common to all 
companies, you are ready to start creating companies in the database.  

To Make a Database Backup 

1. Click Tools > Backup, and the Backup window appears. You use this 
window to specify how extensive you want the backup to be and to 
create the database backup. 

2. Select the type of backup that you want to make. The options are as 
follows: Entire Database, All Companies and Custom. 

3. If you select Custom, you must select the companies that you want 
copied. You do this in the list of companies under Selected 
Companies. It is always a good idea to make backups of as much 
information as possible. If you have to restore a backup later, you do 
not have to restore the whole backup - you can determine how much 
of the backup should be restored. 

4. In the Description field, you must give the backup a unique 
description. 

5. In the File Name field, enter a name. This is the name under which 
the backup is saved. 

Microsoft Dynamics NAV suggests a consecutive numbering and the 
file name extension .fbk. It is a good idea to use this system because 
Microsoft Dynamics NAV uses the same default when you import 
backups. It also gives you a quick overview of the backups that you 
have. The file name of the backup should include the path of the 
folder in which you want to store the backup. 

6. As soon as you have specified the name of the backup, and the drive 
and the folder where you want to save the backup, click OK to start 
making the backup. 

The file name of the backup includes the path (location on the disk or network). 
Therefore, if you enter only a file name, the backup is saved in the current folder 
on the current drive. This is typically in the same location as Microsoft Dynamics 
NAV. If you want to save the backup in a different location (because it uses too 
much space), you have to enter the path together with the name in the File 
Name field. To make this easier, you can click to the right side of the field to save 
the backup with the correct name and in the desired location. 
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While the backup is being made, you can see information about the status of the 
database being copied (at the top of the window) and of the disk that it is being 
copied to. If you change your mind about proceeding with the backup, click 
Cancel at the bottom of the window. If you do not cancel it, the backup 
continues, and you receive a message when it is finished. 

    Note: We recommend that you use the Microsoft SQL Server  backup function 
to make backups of your production databases.  

In practice, you should only use the Microsoft Dynamics NAV backup functions 
when you create a completely new database, or when you want to restore data 
from a specific company in a database.  

To Restore a Database Backup: 

1. Click Tools > Restore, and a standard Windows dialog box appears. 
Use this window to locate the backup that you want to restore. 

2. When you have located the backup, click Open and the Restore 
window appears. The name of the backup appears in the File Name 
field, and you can see the description and the time and date of its 
creation. Further down in the window, you can see what was included 
in the backup: 

o Entire Backup - including all the companies in the database, the 
data common to all companies, and all the application objects. 

o All Companies - all the companies in the database including the 
data common to all companies. 

o Custom - what you chose, for example, certain companies, data 
common to all companies, and the application objects. 
 

3. You can restore less than the complete backup. To do this, clear the 
check boxes next to items that you do not want included. You must 
always include Data Common to All Companies and Application 
Objects if you are restoring the backup into a completely empty 
database. 

4. After you have made your selection, click OK to start restoring the 
backup. A status window on the screen informs you of the progress. 

Restoring the database backup itself does not usually take a long time. But 
because the data is packed, the subsequent process of generating the complete 
data can be time-consuming, depending on the amount of data. 
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Test a Database 

You can also use the Microsoft Dynamics NAV Development Environment to 
determine the state of a database and to correct any database errors. To do this, 
click File > Database > Test to open the Test Database window.  

 

FIGURE 5.7: TESTING A DATABASE WINDOW 

In the Test Database window, you can specify the extent of the test by selecting 
one of these options: Minimum, Normal, Maximum, Custom. 

When you make a selection, the system selects the individual tests that make up 
the test you have selected. The following table lists the features that are tested 
during the different tests. 

Test Type Test Fields Features Checked 

Minimum Test primary keys and 
data. 

All records in all tables 
can be read. 
Records are sorted in 
ascending order 
according to the primary 
key. 
All fields are correct in 
relation to the field type. 

Microsoft Official Training Materials for Microsoft Dynamics ® 
Your use of this content is subject to your current services agreement 

 



Module 5: The Development Environment 

5 - 19 

Test Type Test Fields Features Checked 

 Test BLOBs. All BLOBs (fields for 
pictures - on an item 
card, for example) can be 
read. 

Normal Test primary keys and 
data. 

All records in all tables 
can be read. 

Records are sorted in 
ascending order 
according to the primary 
key. 

All fields are correct in 
relation to the field type. 

 Test secondary keys. All secondary keys in all 
tables can be read. 
Records are sorted in 
ascending order 
according to the 
secondary key. 
All fields are correct in 
relation to the field type. 

 Test space allocation. All space in the database 
is either free or used by a 
sorting key. 

 Test BLOBs. All BLOBs (fields for 
pictures - on an item 
card, for example) can be 
read. 

Maximum All the fields included in 
the Normal test plus the 
following: 

 

 Test relationships 
between primary and 
secondary keys. 

The connection between 
the primary and 
secondary keys is correct. 

 Test field relationships 
between tables. 

All fields that have 
relationships to another 
table can be accessed 
from the table to which 
they are related. 
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Test Type Test Fields Features Checked 

Custom The same fields as the 
Maximum test, but you 
can cancel the tests that 
you do not want to run 

Whatever you select. 

Primary and secondary keys are sometimes described as indexes and are used, for 
example, when you sort information. The keys determine how information in a 
table is ordered. You switch keys when you want to sort according to a different 
key. 

    Note: The Test space allocation test cannot be executed when there is more 
than one user on the system. If you select a test that includes it, and there are other 
people on the system, space allocation is not tested even though the rest of the test 
is executed as usual. 

On the Options Tab in the Test Database window, you can specify how the 
output from the database test is managed. The output from the database test 
consist of the errors messages that are generated. These can be handled as 
follows: 

• Screen: The error messages are displayed on the screen. Every time 
that an error message appears, you must click OK before the test 
continues. This can be troublesome if the test generates many 
messages. 

• Event Log: The error messages are written in the operating system’s 
event log. For more information about the event log, see the 
operating system’s documentation. 

• File: The error messages are written to a text file. Click the field to 
specify the name and location of the text file. 

If you select Event Log or File, the database test is not interrupted and does not 
take so long. You can then review any error messages that were generated and 
repair the things that caused them. 

As soon as you have started the test, a window appears that contains information 
about the test status. 

    Best Practice: Before you run any test, configure Development Environment 
to write test results to a file so that you do not have to acknowledge screen 
messages for every error found. To do this, open the Options tab in the Test 
Database dialog box, click File, and type or browse to a path and file name. 
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Database Information 

In the Database Information window, you can see the current status of your 
database. For example, you can see the size of the database and whether it 
consists of several files. You cannot enter anything in the window. The information 
is mainly interesting to technical personnel. To open the window, click File > 
Database > Information. 

The window has two Tabs: 

Tab / Field Description 

General / Database Server The full name of the SQL Server where 
the Microsoft Dynamics NAV database 
is stored. 
You cannot edit the value in this field. 

General / Database Name The name of the Microsoft Dynamics 
NAV database that is currently open. 
You cannot edit the value in this field. 

General / SQL Edition The edition of SQL Server that is 
running on the database server. 
You cannot edit the value in this field. 

General / Server Instance The server instance name and server 
port of Microsoft Dynamics NAV 
Server. This is the server that is used to 
run objects in the current database. 
Choose the field to change the server 
instance.  
For more information, see “Managing 
Microsoft Dynamics NAV Server 
Instances” and “How to: Change the 
Microsoft Dynamics NAV Server 
Instance” in the online Help. 

Options / Licensed Sessions The maximum number of sessions that 
can be connected to the database with 
the current license. 
To view the current Microsoft 
Dynamics NAV sessions, in the 
RoleTailored client for WIndows, in the 
Search box, type "Sessions", and then 
click the related link. 
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Database Information (Tables) 

The Database Information (Tables) window lists all the tables in the database. 
You can use this information to check how efficiently the database is being used.  

To open this window click File > Database > Information, then click Tables at 
the bottom of the Database Information window that appears. 

Each table has a set of values that tells you how much the database is used.  

For more information, see “Database Information (Tables)” in the online Help. 

Managing Companies 

Companies 

Microsoft Dynamics NAV can access only one logical database at a time, but this 
database can be divided into one or more companies. A company is a "sub 
database," and its primary use is to separate and group data in the same database. 
A company bundles one or more data tables together into a logical superstructure 
that is identified by the company name.  

In principle, you can create as many companies as you want in a database. But in 
practical terms, you are limited by the space on the server and in the database 
that you are using (and the number of companies included in the Microsoft 
Dynamics NAV license file). A company does not require a fixed amount of space, 
and as you can see in the New Company window, you do not have to allocate a 
certain number of kilobytes (KB) to it. But as you gradually enter more and more 
data into the company, less room remains in the database. 

You can use the Development Environment to do the following:  

• Create a new company in a database. 

• Delete an existing company in a database. 

• Change the name of an existing company. 

To delete or rename an existing company, you must first open it in the 
Development Environment.  
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Open a Company 

To open a company in a database, run the Development Environment and then 
click File > Company > Open to open the Companies window. This window lists 
all the companies to which you have access in the current database. To open a 
company, select the company name in the list and then click OK.  

Even when you click File > Company > Open for the first time and you have not 
already created any companies, there can be a company for you to open (if you 
are using the database that contains the demonstration company). This is the 
company that is included with the program. It contains a complete version of 
Microsoft Dynamics NAV and gives examples of how to set up various types of 
data. For example, it contains a chart of accounts, a list of customers, some items, 
and posted entries. 

It can be helpful to spend some time learning about the program by investigating 
the demonstration company. You can recognize the demonstration company 
because its name starts with CRONUS. 

You can use the demonstration company in two ways. If you want to see all the 
facilities in the system (including those for which you have not purchased 
permissions), you must use the license file that is included with the demonstration 
company. It is called cronus.flf, and you can select it by clicking Tools > License 
Information > Change. 

When you examine the demonstration company with your own license file, you 
see only the functions that your license file allows. Your personal license file is 
called fin.flf. You can select it in the same manner as the demonstration license 
file. If you work in a larger network, the license file is typically something your 
system manager provides for you. 

For more information about how to open companies, see “How to: Open 
Companies” in the online Help. 

Delete a Company 

Periodically, you might have to delete a company in the database. To do this, 
open the company in the Development Environment and then click File > 
Company > Delete. The program asks you to confirm (two times) that you want 
to delete the company. To delete the company, confirm that you want to delete 
the company. 

When you delete a company, the whole company including all the data that it 
contains is deleted. If you have made reports and customizations, they are not 
deleted. They are saved in the database. 

It is not as dangerous to delete a company as it is to delete a database. However, 
we recommend you make a backup before you delete it. 
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When you choose to delete the company in this manner, the system asks you two 
times whether you really want to delete the company. 

For more information about how to delete companies, see “How to: Delete 
Companies” in the online Help. 

Create a Company 

In principle, you can create as many companies as you want, but in practical terms 
you are limited by the space on the server and in the database that you are using. 
A company does not use a fixed amount of space, and as you can see in the New 
Company window, you do not have to allocate a certain number of kilobytes (KB) 
to it. But as you gradually enter more and more data into the company, less room 
remains in the database. 

To create a company, start the Development Environment and open the database 
where you want to add a new company. Click File > Company > New to open 
the New Company window.  In the Company Name field, enter the name of the 
new company. Click OK to close the New Company window. 

You can give the company any name that you want. But if you create a company 
whose name starts with CRONUS (all in uppercase letters) while you work under a 
demonstration license file, the company automatically becomes a demonstration 
company, with all the restrictions that implies (you can only post between 
November and February, and so on). 

The company name can have no more than 30 characters. The company name is 
case-sensitive, that is, it differentiates between uppercase and lowercase letters. 
So, you can have one company called COMPANY and another called Company. 

When you create the company name, remember that it is written at the top of 
various reports, so write it exactly as you want it to appear.  

For more information about how to create companies, see “How to: Create 
Companies” in the online Help. 

Rename a Company 

If you make a mistake while entering the name of a new company, or if you want 
a different one, you can always rename it. To do this, open the company in the 
Development Environment and then click File > Company > Rename to open 
the Rename Company window. Replace the current name with the new name 
and then click OK to close the window. 

Before you rename a company, verify that you are working in the company that 
you want to rename and that you are the only user who has access to the 
company.  
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Renaming a company that has been used and already contains data can take 
some time. 

When you work in the demonstration database that is included with the program, 
using the cronus.flf license file, you can only change the company name to one 
that begins with CRONUS (with uppercase letters). 

For more information about renaming companies, see “How to: Rename 
Companies” in the online Help. 

Managing Licenses 

The Demo License 

When you install the RoleTailored client for Windows, the demo license is 
automatically installed. The demo license works with the CRONUS demo database, 
has serial number 000, and includes granule 540. The license allows access to the 
whole base application and limited access to the development system. 

At first, Microsoft Dynamics NAV uses CRONUS.flf, which is the demonstration 
license file. All license files that are not demonstration license files are named 
FIN.flf. The demonstration license file has a different name so that it cannot be 
mistakenly overwritten. 

When the demo license is installed, you can do the following: 

• Start up to two concurrent client sessions on any platform. 

• Create up to two companies. 

• Support an unlimited number of web users. 

• Run with databases of up to 500 MB. 

• Run in any supported language.  

• Use all application functionality, including add-in products, local 
extensions, and customizations in current and earlier versions. This 
means that you can run, but not modify, all object types within the 
range 1 to 99,999,999.  

• Run and modify table 18, forms 21 and 22, report 101, and XMLports 
99,008,503 and 99,008,510. 

• Run, modify, and create fields 99,990 to 99,999, form 99,999, report 
99,999, and MenuSuite 90. 

However, the demo license does not offer you unlimited access to the Microsoft 
Dynamics NAV application. 
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Constraints of the Demo License 

The demo license does not allow you to do the following: 

• Import objects in text format, except for form and report ID 99,999. 

• Make more than 4,000 transactions in a database. 

• Enter dates in months other than November, December, January, and 
February. 

A transaction is any action that requires interaction with the database. This 
includes posting an order, posting a worksheet, and synchronizing a record. 

Country/Region Versions 

When you run a country/region version of Microsoft Dynamics NAV, the license 
must correspond to the country/region version that you have installed.  

Any license can be available in different country/region versions. For example, 
Spanish license ES 4.00 SP2 completely installed can only run with a license serial 
number ES-ZA-xxx-xxxxx-x; Spanish license ES 4.00 SP2 database that has a W1 
4.00 SP2 completely installed can only run with a license serial number W1-ZA-
xxx-xxxxx-x. 

License Information 

The License Information window shows the contents of the current license file. 
The information displayed includes the license number, the name of the license 
owner, which application granules are included, and when the license expires. 
Typically when you are working, your own serial number and the name of your 
company appears in the window. 
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You do not have to use the License Information window in your daily work with 
companies. However, if you have to speak to your dealer about expanding the 
program, special modifications, or any problems, you have to open it. To open the 
window, click Tools > License Information. 

 

FIGURE 5.8: THE LICENSE INFORMATION WINDOW 

The buttons in the License Information window are as follows: 

Button Description 

Upload Used to upload your license file to the SQL 
Server that you want to access. The license 
information is used by all the client computers 
that connect to this server unless a database 
license file is being used. 

Change Used for a temporary change of license file. 
This function makes sure that the change is 
not saved the next time that you start the 
program, and your old license file is used. You 
must make sure that you use this if you want 
to use the demonstration license file cronus.flf. 
Otherwise, you may overwrite your own 
license file. 

Microsoft Dynamics NAV warns you before your license expires. If you let the 
license on the server expire, you will be unable to access the server. However, you 
can use the Change function to access the server by using an alternative 
(renewed) license file (and then upload the new license file). 

Each of the two functions uses the same type of standard Windows dialog to 
locate the license file. When you have located the license file, click Open to have 
the system upload or change the license file.  
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Upload the License 

After an administrator or a Microsoft Certified Partner first installs Microsoft 
Dynamics NAV, the next step is to install the license file that is supplied by 
Microsoft. You install the license by uploading it to the Microsoft SQL Server that 
runs the Microsoft Dynamics NAV database.  

    Note: You can also upload the license by using the PowerShell API. For more 
information about this, see the Microsoft Dynamics PowerShell module in this 
course.  

Uploading the license file is typically something that you do once for each 
database installation, not once for each client installation. The license file is saved 
in the Microsoft SQL Server master database and applies to all Microsoft Dynamics 
NAV databases on that instance of SQL Server.  

However, Microsoft Dynamics NAV lets you upload a license for a specific 
database only. In this case, the license file is saved in the Microsoft Dynamics NAV 
database and applies only to that database. To save the license file in the 
database, be aware of the following:  

• You must have the Per Database license granule (2020) in your 
license. 

• You must activate the Save license in database option in the New 
Database or Alter Database window. 

Upload the License to an Instance of SQL Server (All Databases) 

The following procedure shows how to upload the license file to SQL Server. 

    Note: On a computer that is running any version of Windows with User 
Access Control enabled, you must start the Development Environment with 
administrative credentials. Right-click Microsoft Dynamics NAV 2013 
Development Environment on the Start menu, and then click Run as 
administrator. 

1. Start the Development Environment.  
2. Verify that you are connected to your database. On the File menu, 

click Database > Open.   

3. On the Tools menu, click License Information.  
4. In the License Information window, click Upload.  
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5. In the Upload License File dialog box, browse to and open the 
license file.  
The following message appears:  "The Server license was successfully 
uploaded". 

6. Restart the Development Environment to activate the license if you 
want to use it to work in the Development Environment. 

Upload a License File for a Specific Database Only 

To upload a license file for a specific database only, you must use the Alter 
Database window: 

1. In the Development Environment, on the File menu, click Database > 
Alter. 

2. In the Alter Database window, click Integration, and then select 
Save license in database. 

3. Click OK to close the Alter Database window. 
4. In the Upload License File dialog box, browse to and open the 

license file.  

Managing Objects 
The Development Environment can be used to modify the application or create 
new application areas.  

Object Designer 

When you run the Development Environment and open a database, you see the 
Object Designer window.  

The Object Designer window is the single entry-point to the Integrated 
Development Environment of Microsoft Dynamics NAV 2013. It is the starting 
point for modifying the application and for creating new application areas.  

In the Object Designer, you can create new Microsoft Dynamics NAV objects and 
modify existing objects. You can also import and export Microsoft Dynamics NAV 
objects in different formats. More information about how to create, modify, 
import, and export objects, is covered in the course C/SIDE Introduction in 
Microsoft Dynamics NAV 2013.  

If you close the Object Designer window, you can open it in the following ways: 

• Click Tools > Object Designer. 

• Press Shift+F12.  
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Lab 5.1: Create a Development Environment 
Scenario 

To this point, Tim has created two databases: a production database (with the real 
company data) and a test database (which is a recent copy of the production 
database). He plans to update the test environment every Saturday by restoring a 
full backup of the production database in the test environment. (The existing test 
environment will be overwritten.) Tim suddenly realizes that Mort is also using the 
test environment for his development activities. Therefore, he cannot overwrite 
the test database without destroying Mort’s work. Tim decides to create a third 
environment, the Development Environment. To make sure that he keeps all 
approved customizations, Tim plans to take the application objects from the 
production database.  

Exercise 1: Make a Backup of the Production Database 

Task 1: Start the Development Environment 

High Level Steps 
1. Start Microsoft Dynamics NAV 2013 Development Environment. 

Detailed Steps 
1. Start Microsoft Dynamics NAV 2013 Development Environment. 

a. Click Start > All Programs > Microsoft Dynamics NAV 2013 
Development Environment. 

Task 2: Open the Production Database 

High Level Steps 
1. Open the production database. 

Detailed Steps 
1. Open the production database. 

a. Click File > Database > Open. 
b. In the Server Name field, enter the name of the SQL Server that 

runs the production database. In this case: NAV-DC-SQL-SP. 
c. In the Database Name field, enter NAV_DEMO2013_LIVE.  

d. In the Authentication drop-down list, select Windows 
Authentication. 

e. Click OK to close the Open Database window. 
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Task 3: Select Backup Type 

High Level Steps 
1. Start backup procedure. 

Detailed Steps 
1. Start backup procedure. 

a. Click Tools > Backup. 
b. In the Backup window, select the Custom option. 

c. In the Selected Companies list, make sure that the CRONUS 
International Ltd. company is selected.  

d. Make sure that the Data common to all companies and 
Application Objects options are selected. 

e. In the Description field, type a short description for the backup. 
In this case, you can type "LIVE DB Backup – To Create DEV DB". 

f. In the File Name field, type the path and file name for the 
backup. In this case, you can type  
"C:\Users\Administrator\Desktop\CH5_LIVEDB.fbk". 

Task 4: Start Backup 

High Level Steps 
1. Start backup. 

Detailed Steps 
1. Start backup. 

a. In the Backup window, click OK to start the backup procedure.  
b. When the backup has finished, a message appears on the screen. 

Click OK to close the message. 

Task 5: Close the Production Database 

High Level Steps 
1. Close the production database. 

Detailed Steps 
1. Close the production database. 

a. Click File > Database > Close to close the production database. 
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Exercise 2: Create a New Database 
Exercise Scenario 

Tim creates a new database for development. 

Task 1: Connect to the SQL Server 

High Level Steps 
1. Connect to the SQL Server. 

Detailed Steps 
1. Connect to the SQL Server. 

a. Click File > Database > New. 
b. In the Server Name field, type the name of the SQL Server where 

you want to create the database. In this case, type "NAV-DC-SQL-
SP".  

c. In the Authentication field, select Windows Authentication. 
d. Click OK to connect to the SQL Server.  

Task 2: Create a Database 

High Level Steps 
1. Create a new database. 

Detailed Steps 
1. Create a new database. 

a. On the General tab, in the Database Name field, enter 
NAV_DEMO2013_DEV. 

b. On the Collation tab, click the Case-sensitive check box to clear 
the selection.  

c. On the Options tab, in the Recovery model field, select Simple. 

d. Click OK to create the database.  

Exercise 3: Restore a Backup in the Development Database 

Task 1: Open the Development Database 

High Level Steps 
1. Open the development database. 

Detailed Steps 
1. Open the development database. 

a. Click File > Database > Open. 
b. In the Server Name field, enter NAV-DC-SQL-SP. 
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c. In the Database Name field, enter NAV_DEMO2013_DEV. 
d. In the Authentication field, select Windows Authentication. 

e. Click OK to open the database. 

Task 2: Select the Backup File to Restore 

High Level Steps 
1. Select the backup file to restore. 

Detailed Steps 
1. Select the backup file to restore. 

a. Click Tools > Restore. 
b. In the Restore dialog box, browse to the CH5_LIVEDB.fbk backup 

file (in the C:\Users\Administrator\Desktop folder). 

c. In the Restore dialog box, click Open. 

Task 3: Restore Application Objects and Common Data 

High Level Steps 
1. Restore Application Objects and Common Data. 

Detailed Steps 
1. Restore Application Objects and Common Data. 

a. In the Restore window, click the Selected Companies field to 
clear the selection. 

b. Make sure that the Data common to all companies and 
Application Objects options are selected.  

c. Click OK to start the restore. 
When the restore is finished, you receive the “The ‘LIVE DB – 
Create DEV Env.’ Backup was successfully restored” message. 

d. Click OK to close the message. 

Task 4: Close the Development Database 

High Level Steps 
1. Close the development database. 

Detailed Steps 
1. Close the development database. 

a. Click File > Database > Close to close the development 
database. 
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Lab 5.2: Restore Company Data 
Scenario 

When Mort opens the development database, he notices that there is no 
company and no company data in the database (except for the common data). He 
can create a new company but then he still has to enter data himself. Mort asks 
Tim to restore the company data from the production or the test database in the 
development database.  

Exercise 1: Restore a Company in the Development 
Database 

Task 1: Open the Development Database 

High Level Steps 
1. Open the development database. 

Detailed Steps 
1. Open the development database. 

a. In the Microsoft Dynamics NAV 2013 Development Environment, 
click File > Database > Open. 

b. In the Server Name field, enter NAV-DC-SQL-SP. 

c. In the Database Name field, enter NAV_DEMO2013_DEV. 
d. In the Authentication field, select Windows Authentication. 
e. Click OK to open the database. 

Task 2: Select the Backup File to Restore 

High Level Steps 
1. Select the backup file to restore. 

Detailed Steps 
1. Select the backup file to restore. 

a. Click Tools > Restore. 

b. In the Restore dialog box, browse to the CH5_LIVEDB.fbk backup 
file (in the C:\Users\Administrator\Desktop folder). 

c. In the Restore dialog box, click Open. 
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Task 3: Restore a Company 

High Level Steps 
1. Restore a company. 

Detailed Steps 
1. Restore a company. 

a. In the Restore window, click the Custom option. 
b. In the Selected Companies list, select the CRONUS International 

Ltd. company.  
c. Click OK to start the restore. 

When the restore is finished, you receive the “The ‘LIVE DB – 
Create DEV Env.’ Backup was successfully restored” message. 

d. Click OK to close the message.  

Task 4: Close the Development Database 

High Level Steps 
1. Close the development database. 

Detailed Steps 
1. Close the development database. 

a. Click File > Database > Close to close the development 
database. 
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Lab 5.3: Alter the Database 
Scenario 

When he starts developing, Mort notices that all new controls, variables, and text 
constants are assigned IDs starting from 1,000,000,000. This makes it difficult to 
trace the origin of a specific control. To structure his customizations, Mort want to 
assign IDs starting from 90,000. So, he asks Tim to change the Start ID 
(UidOffset) parameter for the development database.  

Exercise 1: Change the Start ID (UidOffset) Parameter 

Task 1: Open the Development Database 

High Level Steps 
1. Open the development database. 

Detailed Steps 
1. Open the development database. 

a. In the Microsoft Dynamics NAV 2013 Development Environment, 
click File > Database > Open. 

b. In the Server Name field, enter NAV-DC-SQL-SP. 

c. In the Database Name field, enter NAV_DEMO2013_DEV. 
d. In the Authentication field, select Windows Authentication. 
e. Click OK to open the database. 

Task 2: Alter the Database 

High Level Steps 
1. Open the Alter Database window. 

2. Change the database setting. 

Detailed Steps 
1. Open the Alter Database window. 

a. Click File > Database > Alter. 
 

2. Change the database setting. 
a. On the Advanced Tab, in the Start ID (UidOffset) field, type 

"90000". 
b. Click OK to close the Alter Database window. 
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Task 3: Close the Development Database 

High Level Steps 
1. Close the development database. 

Detailed Steps 
1. Close the development database. 

a. Click File > Database > Close to close the development 
database. 

  

Microsoft Official Training Materials for Microsoft Dynamics ® 
Your use of this content is subject to your current services agreement 

 



Installation and Configuration in Microsoft Dynamics® NAV 2013 

5 - 38 

Module Review 
Module Review and Takeaways 

The Development Environment lets you manage databases, companies, objects, 
and licenses.  

Test Your Knowledge 

Test your knowledge with the following questions. 

1. Which functions does the License Information window have? 

(   ) Import, Export 

(   ) Upload, Import, Export, Change, Delete 

(   ) Upload, Import, Export, Change 

(   ) Upload, Change 

(   ) Upload, Download 

2. How many companies can you create in a Microsoft Dynamics NAV database? 

(   ) 1 

(   ) 2 

(   ) 5 

(   ) 99 

(   ) Unlimited 

3. What is TRUE about the Development Environment? 

(   ) It can be installed as an alternative for the RoleTailored client. 

(   ) It connects to the Microsoft Dynamics NAV database through 
Microsoft Dynamics NAV Server. 

(   ) It has a multilanguage-enabled user interface. 

(   ) It must be used to manage database users. 

(   ) It is the recommended tool for making backups of production 
databases. 
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Test Your Knowledge Solutions 

Module Review and Takeaways 

1. Which functions does the License Information window have? 

(   ) Import, Export 

(   ) Upload, Import, Export, Change, Delete 

(   ) Upload, Import, Export, Change 

(√) Upload, Change 

(   ) Upload, Download 

2. How many companies can you create in a Microsoft Dynamics NAV database? 

(   ) 1 

(   ) 2 

(   ) 5 

(   ) 99 

(√) Unlimited 

3. What is TRUE about the Development Environment? 

(   ) It can be installed as an alternative for the RoleTailored client. 

(   ) It connects to the Microsoft Dynamics NAV database through 
Microsoft Dynamics NAV Server 

(√) It has a multilanguage-enabled user interface. 

(   ) It must be used to manage database users. 

(   ) It is the recommended tool for making backups of production 
databases. 
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