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MODULE 8: REPORTS 

Module Overview 
Reports print information, structure, and summarize information. Use reports to 
print documents such as invoices, and to process data without printing. 

Creating reports includes designing both the business logic that covers the 
information the report contains, and the print layout of the report. 

Objectives 

The objectives are:  

• Explain the concepts of reports and report components. 

• Provide an overview of different report types and their characteristics. 

• Describe the difference between the logical and the visual design of 
reports and introduce Report Designer. 

• Describe the logical design of a report. 

• Create the data model for a new report by defining data items in the 
Report Dataset Designer. 

• Describe the visual design of a report and introduce Microsoft Visual 
Studio Report Designer. 

• Design the report layout. 

• Introduce Request Page Designer. 

• Design the Request Options page. 

• Explain the concepts of grouping and totaling in a report. 

• Create a grouping and totaling for a report. 

• Add advanced features to a report. 
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Reports Fundamentals 
In Microsoft Dynamics NAV, reports have the following purposes: 

• Structure and print information from a database. For example, report 
108, Customer - Order Detail lists all customers and all sales orders 
for each customer.  

• Print and display documents in the application. For example, report 
206, Sales - Invoice prints an invoice together with its relevant 
information.  

• Automate many recurring tasks, such as updating all prices in an item 
list. This can be performed by using C/AL code in a codeunit, but 
report makes it easier because of the powerful data modeling that is 
available for report design, such as report 794, Adjust Item 
Costs/Prices.  

A report consists of the report description that specifies how data is collected, 
presented on the screen, or printed on the paper when the report is run. 

The report description is not directly visible to the user. When developers create 
reports, they perform the following task to establish the report description: 

• Assign the report name and ID number. 

• Specify data items. 

• Design the layout of the report. 

The report description contains the following: 

• Properties 

• Triggers 

• Controls 

• Data items 

• Columns 

• Request page labels 

• Layout.  

The “Report Description” figure shows components of a report and how they are 
related. 
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FIGURE 8.1: REPORT DESCRIPTION 

Properties 

The report description contains properties that are related to the report, and 
properties that are related to the other report components, such as data items, 
columns, and the Request page. 

A property is an attribute of an object or its components that characterizes and 
specifies behavior of the parent, such as whether it is visible.  

Triggers 

Certain predefined events that occur in a report cause the system to execute a 
user-definable C/AL function. The event and the function together are called a 
trigger. 

Triggers in a report can be divided into the following three categories: 

• Report triggers  

• Data item triggers  

• Request page triggers  
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Examples of report triggers include OnPreReport that contains statements that are 
executed right before the report is run, and OnPostReport that contains 
statements that are executed immediately before the report execution completes. 
Edit triggers in a report by using the C/AL Editor, which is accessed from Report 
Dataset Designer. 

Data Items 

You build the data model of a report from data items; data items correspond to a 
table. When the report runs, each data item is iterated for all records in the 
underlying table. When a report is based on more than one table, you establish a 
hierarchy of data items to control how the information is collected. You establish 
this hierarchy by indenting the data items.  

For example, to create a report that prints a list of customers, and sales orders that 
are created by each customer, you define the following two data items: 

• One that corresponds to the Customer table.  

• One that corresponds to the Sales Order table. (This data item is 
indented.)  

The report examines all customers in the Customer table, and all sales orders in 
the Sales Order table to find all sales orders that are related to this customer.  

Columns  

You use Report Dataset Designer in Microsoft Dynamics NAV Development 
Environment to define the dataset of a report. You build the report dataset from 
data items and columns. 

A data item is a table. A column can be any of the following:  

• A field in a table 

• A variable 

• An expression 

• A caption that is not related to a specific table 

Request Page 

The Request page collects requests and options from users before the actual 
report begins execution. The request page runs at the same time that the report 
runs. Request pages enable end-users to specify options and filters for a report. 
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Labels 

You can add labels to the dataset with Report Dataset Designer. Labels can be 
related to a data item, such as the caption for a table field. Labels can be 
unrelated to a data item, such as the title of the report. 

When you create a report layout in Visual Studio, you add data items from the 
Visual Studio dataset to the layout. If you want to add a label to the report layout, 
such as a caption for a field, a title for a chart, or a title for the report, then you 
must have a label in the Visual Studio dataset. 

To add a caption for a field, use the Include Caption property. To add labels to the 
report, use Report Label Designer. 

Layout 

Reports in Microsoft Dynamics NAV can be a printing or nonprinting report. Use a 
nonprinting report for processing a task that does not produce a displayed 
output. A printing report displays the result in the screen or generates print 
output. This display is controlled by the client report definition (Report Definition 
Language Client-side, or RDLC) layout of the reports. 

You use Visual Studio Report Designer to design the RDLC layout. You display 
most of the data in the body of a report; you use the header to display 
information before any data item record is displayed. For example, you can 
display a report title, company, and user information in the header of a report. 

With Visual Studio Report Designer, you can add useful features to your report 
layouts, such as the following: 

• Links from a field on a report to either a page or another report 

• Images and graphs 

• The ability to toggle columns so that you can hide or display data 

• The ability for users to interactively change the column on which data 
in the report is sorted 
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Report Design Process 
The report design process is divided into two distinct phases that reflect different 
aspects of creating a report. They are as follows: 

• Defining the logical structure (the data model)  

• Designing the visual element  

In addition, there are occasions when a user must input certain options before 
they run the report through the Request page. Therefore, the report design 
process also designs the request page.  

Logical Design 

Creating a logical design for a report means defining the data model. This means 
defining how the data for the report is collected. This includes defining the 
following: 

• Tables that are used by the report by defining data items  

• Relationships between data items if the report uses more than one 
table  

• Key, sort order, and filters to use with the data items  

• Elements that the user can change at run time  

• Grouping of data  

• Calculation of subtotals and totals  

Visual Design 

Designing a report's visual elements to create an RDL data for a report.  

Demonstration:  Report Dataset Designer 

Define a logical report in the Report Dataset Designer.  

The Report Dataset Designer contains the following designers:  

• The Request Options Page Designer. An additional designer that 
you use to design request options pages.  

• Microsoft Visual Studio Report Designer. An external designer that 
you use to create the RDL data for layout of reports. 
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Demonstration Steps 

1. The following steps show how to open Report Dataset Designer:  
a. Click Tools > Object Designer.  
b. Click Report to open the Report list.  
c. Select any report, and then any of the following: 

 Click Design to open Report Designer to design the 
report. 

 Click New to open Report Designer to design a new 
report. 

Design the Data Model 
Define a data model in Report Dataset Designer by adding data items. In this 
window, specify the tables that the report reads. Any table that is listed in this 
window is read in its entirety when the report runs. Link and filter data items to 
limit the number of records that the report reads. 

A report can read the same table multiple times if the table is listed multiple times 
in Report Dataset Designer. For example, you can set up a report to read customer 
records twice: first, the customers who are not blocked, and then the customers 
who are blocked. 

The listed tables become data items in the report. Data items are record variables 
that enable the report to access table data. The “Report Dataset Designer” figure 
shows the Customer List report. 

 

FIGURE 8.2: REPORT DATASET DESIGNER 
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The Customer table is the data item for this report. The Name column in Report 
Dataset Designer displays the name that is used by the report for the data item. 
All variable names must be unique within the report. 

Ordering and Indenting Data Items 

The order in which the data items are listed is the order in which the report reads 
the data from the tables. At the bottom of the Report Dataset Designer window, 
there are four arrow buttons. Use the up and down arrow buttons to reorder the 
data items.  Use the right and left arrow buttons to indent or remove the 
indentation of a data item. 

If a data item is indented under another data item (the parent data item), the 
report reads every record from the parent data item and all records from the 
indented data item, including any filters or links.  

This concept resembles a nested FOR loop. For example, if the Sales Line table is 
added as a data item under Customer table, and then it is indented, the report 
reads the customer, and then the relevant sales line information for that customer, 
before it moves to the next customer. 

Linking a Data Item 

Each data item has the DataItemLinkReference property and the DataItemLink 
property. These properties define a Master/Detail relationship between two tables. 

In the DataItemLinkReference property of a data item, select the parent data item 
to link to (the data item must be indented under the parent data item). 

In the DataItemLink property of the indented data item, specify a filter for this 
data item by matching fields in this data item with fields from the parent data 
item in the DataItemLinkReference property. 

Adding columns 

After you add a data item to a report, you add columns to the data item. A 
column can be a field in a table, a variable, or an expression. Columns correspond 
to fields in a table. 

To add a column in Report Dataset Designer, do the following: 

1. On the first blank line, in the Data Type column, select Column from 
the drop-down list. 

2. Click View > Field Menu. The Field Menu window opens, and 
displays the list of available fields from the data item. 
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3. In the Field Menu window, select one or more fields that you want to 

add to the report dataset. Select multiple fields by holding down the 
SHIFT key or the CTRL key.  

4. Click OK to add the selected fields to the dataset. 
5. If you want to include the caption of a column in the dataset, then 

select Include Caption in Report Dataset Designer. The caption is 
included as a parameter in Visual Studio Report Designer. 

6. If the Include Caption column is not visible in Report Dataset 
Designer, then click View > Show Column on the Toolbar. Select 
Include Caption, and then click OK. 

7. In Report Dataset Designer, enter data items and columns until you 
have added all fields from the tables that you want to include in the 
report. 

8. If you want to add a label to the report, such as a caption for a table 
header or a title for the report, then add a label to the dataset. 

If you want to include a variable in the report dataset, then do the following: 

1. In Report Dataset Designer, on a blank line in the Data Type column, 
select Column from the drop-down list. 

2. In the Data Source column, enter the variable. You can use the up 
arrow to open the C/AL Symbol Menu dialog box and view the 
variables for the report.  

3. In Report Dataset Designer, in the Name column, enter a CLS-
compliant name for the variable. This name is used in the dataset in 
Visual Studio. 

If you want to include a calculation or other source expression in the report 
dataset, then do the following: 

1. In Report Dataset Designer, on a blank line in the Data Type column, 
select Column from the drop-down list. 

2. In the Data Source column, enter the source expression. 
3. In the Name column, enter a name for the variable. This name is used 

in the dataset in Visual Studio. 
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Creating a Data Model 
The following demonstrations assist you in understanding the basic design 
principles of creating a report in Microsoft Dynamics NAV. The report that you 
create in these demonstrations shows a list of customers by salespersons. 

The following demonstration shows how to do the following: 

• Create a data model by defining data items. 

• Create linking between data items. 

• Define appropriate sorting for the data item in the Report Dataset 
Designer. 

Demonstration:  Prepare the Customer Table 

Demonstration Steps 

1. Before you start the report, add a key to the Customer table. 

a. Select Design table 18, Customer, from Object Designer. 
b. Click View > Keys, and add Salesperson Code to the list of keys. 

See “The Customer Table Keys” figure. 

 

FIGURE 8.3: THE CUSTOMER TABLE KEYS 

c. Close the Keys window and compile, save, and then close the 
table. 
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Demonstration:  Create the Report Data Model 

Demonstration Steps 

1. The following steps show how to create the business logic for the 
report in the Report Dataset Designer: 
a. In Object Designer Report List, click New. The Report Designer 

opens. 
b. Click the first empty line in the Report Dataset Designer, and 

type or select the number or name of table 13, 
Salesperson/Purchaser in the DataItem column. The Name 
column is set by default to the table name. 

c. Click the next line, and add table 18, Customer. 
 

2. The report must show customers by salesperson. Therefore, it must 
first read the Salesperson/Purchaser table, and for each salesperson 
record, it must read all customers for that salesperson. To do this, 
indent the Customer data item under the Salesperson/Purchaser 
data item, and link the two. 
a. With the Customer data item still selected, click the right arrow 

button at the bottom of the Report Designer to indent the 
Customer data item. See “The Customer Data Item Indented 
Under the Salesperson/Purchaser Data Item” figure. 

 

FIGURE 8.4: THE CUSTOMER DATA ITEM INDENTED UNDER THE 
SALESPERSON/PURCHASER DATA ITEM 

 

b. Open the Properties window for the Customer data item. 
c. Locate the DataItemLinkReference property, and verify that it is 

set to Salesperson/Purchaser. 
d. Locate the DataItemLink property, and then click AssistEdit(…) 

on the DataItemLink property.  
e. The DataItem Link window opens. 

 

Microsoft Official Training Materials for Microsoft Dynamics ® 
Your use of this content is subject to your current services agreement 

 



C/SIDE Introduction in Microsoft Dynamics® NAV 2013 

8 - 12 

 
 

f. Type the following in the DataItem Link window: 

Salesperson Code=FIELD(Code) 

g. This links the Salesperson Code field from the Customer table 
to the Code field from the Salesperson/Purchaser table. 

h. Click OK to close the DataItem Link window.  
i. Locate the DataItemTableView property, and then click 

AssistEdit(…) on the DataItemTableView property. The Table 
View window opens.  

j. In the Key field, select Salesperson Code, and then click OK to 
close the Table View window. This sorts the indented data item 
by the indicated field. This is best practice when linking two data 
items.  

Notice that the DataItemTableView property is set to the following: 

SORTING(Salesperson Code)  

k. Close the Properties window.  
l. Compile and save the report by clicking File > Save As. The Save 

As dialog box appears.  
m. Type “90000” in the ID, and Customer by Salesperson in the 

Name.  

n. Make sure that Compiled is selected, and then click OK. This 
compiles and saves the report.  

The report data model is now complete. The next step is to design the visual 
element of the report. 

Demonstration:  Add columns and captions to the data 
model 

Demonstration Steps 

1. Add columns to the Report Dataset Designer 
a. In Report Dataset Designer, select the first line that contains the 

Salesperson/Purchaser data item. 
b. Click the Field Menu button in the toolbar to open the Field 

Menu window. 
c. In the Field Menu window, select the first two lines. 

d. Click OK in the Field Menu window. A confirmation message 
appears. 
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e. Click Yes. Two columns are added to Report Dataset Designer, 

below the Salesperson/Purchaser data item as shown in the 
“Adding Columns” figure.  

 

FIGURE 8.5: ADDING COLUMNS 

f. Repeat this process for the Customer data item, and add the 
following fields to the Customer data item: 

 No. 

 Name 

 City 

 Phone No. 

2. After the columns are added in the data items, include caption. 

a. In the Report Dataset Designer for the No. field, select the 
Include Caption column. A toggle appears in the Include Caption 
column. 

b. Repeat this for all fields of the Salesperson/Purchaser and 
Customer data items. 

c. The Report Dataset Designer now looks like the “Include 
Columns in report Dataset Designer” figure. 
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FIGURE 8.6: INCLUDE COLUMNS IN REPORT DATASET DESIGNER 

Designing the Layout 
The report's visual elements are the Microsoft Visual Studio Report Designer. 

Microsoft Visual Studio Report Designer 

The Report Definition Language (RDL) Data is a report component that is used by 
Microsoft Dynamics NAV to display the report in the RoleTailored client. 
Microsoft Visual Studio Report Designer is an external designer that is used to 
design the visual element (the RDL data) of a report. It is accessed from the 
Report Dataset Designer. The following steps show how to open the Microsoft 
Visual Studio Report Designer: 

1. Open Report Dataset Designer from Object Designer. 
2. In Report Designer, click View, Layout. 

The Report Designer provides the following two options about layout creation:  

• View Layout  

• Delete Layout 

You can access these two options on the Tools menu in the Development 
Environment. 

The View, Layout option creates an (empty) report.rdlc file, and opens it in Visual 
Studio Report Designer. 

The Delete Layout option deletes the current report layout. 
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Demonstration:  Designing the Layout 

The following demonstration shows how to design the report layout in Microsoft 
Visual Studio Report Designer. 

Demonstration Steps 

1. Prepare the Layout: 
The following steps show how to design the report layout in 
Microsoft Visual Studio Report Designer. 

a. Design report 90000, Customer by Salesperson, from the 
Object Designer. 

b. Click View, Layout.  
Microsoft Visual Studio Report Designer opens with a Dataset 
Result from the report dataset designer. 

c. Drag a Table control from the toolbox to the report layout. 
d. Click one of the columns, right-click, and then click Insert 

Column to the Right. See “The Table with Four Columns” figure. 

 

FIGURE 8.7: THE TABLE WITH FOUR COLUMNS 

The layout now has a table with four columns. 

2. Add Column Headers 
a. Type [@No_CustomerCaption] in the first column of the first row 

of the table.  

b. Use the caption fields for column headings instead of hard-coded 
text, to support a multilanguage scenario.  

c. Repeat this for the following fields in the appropriate columns of 
the first row of the table: 

 [@Name_CustomerCaption]  

 [@City_CustomerCaption] 

 [@PhoneNo_CustomerCaption]  
 

d. You can also complete these fields by going to the individual text 
box in the table and typing the Value property appropriately. See 
the “The Report Layout” figure. 
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FIGURE 8.8: THE REPORT LAYOUT 

3. Add a Grouping: 
A dataset result in Visual Studio Report Designer is flattened data. 
This means the Salesperson/Purchaser table and the Customer 
table are joined.  
In the Visual Studio Report Designer, the hierarchy is defined in 
each control, in this case, the table control. The following steps show 
how to add the grouping of customers by their salesperson. 
a. In the Properties window, select the Table properties and set the 

property DataSetName to DataSet_Result. This connects the table 
to the dataset. When you add a field from the dataset to the 
table, the table is automatically connected to the dataset. In this 
example, a group is created in a table that does not contain fields 
from the dataset. 

b. In the Grouping panel at the bottom of the page, click the Row 
Group arrow and click Add Group > Parent Group. See the  
”Add Parent Group to Table” figure. 

 

FIGURE 8.9: ADD PARENT GROUP TO TABLE 

c. The Group Properties window opens. Select Group by, and then 
select  [Code_SalespersonPurchaser]. 

d. Select Add group header and Add group footer as shown in 
Tablix Group. See the “Tablix Group” figure. 
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FIGURE 8.10: TABLIX GROUP WINDOW 

e. Click OK. 
f. In the first text box of the first row, change the expression for the 

value to the following: [@Name_SalespersonPurchaserCaption]. 
g.  Right-click the column header of this text box header and select 

Insert Column > Inside Group – Left as shown in Add Column 
Inside. 

 

FIGURE 8.11: ADD COLUMN INSIDE 

h. In the first text box of the first row, set the expression for the 
value to the following: [@Code_SalespersonPurchaserCaption]. 

i. In the first text box of the second row, set the expression for the 
value to the following: [Code_SalespersonPurchaser]. The “Report 
Layout” figure shows the layout. 

 

FIGURE 8.12: THE REPORT LAYOUT 
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4. Add fields: 

The following steps show how to add fields to the report layout. 
a. In the text box, on the third row of the third column, select 

No_Customer from the menu. The [No_Customer] field is added 
to the text box. 

b. Repeat this step for the next three columns to add the fields:  
 [Name_Customer] 

 [City_Customer] 

 [PhoneNo_Customer] 

The “Report Layout” figure shows how the layout should look: 

 

FIGURE 8.13: THE REPORT LAYOUT 

c. Close Visual Studio and then click Yes when you are prompted to 
save the changes.  

d. Click anywhere in the Report Designer, and then click Yes to 
load the saved changes from Visual Studio.  

e. Compile, save, and then close the report. 

 
5. Run the Report: 

In the RoleTailored client, a report is run from a page. However, to 
test the changes, run the report from Object Designer. 
a. In Object Designer, select the report 90000, Customer by 

Salesperson. 
b. Click Run. 

c. The Request page opens. This page lets users enter filters for 
data items or change the sorting. Users can also choose to print 
or preview the report. See the “Request Page” figure. 
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FIGURE 8.14: THE REQUEST PAGE 

 

d. Click Preview. See the “Print Preview Window” figure. 

 

FIGURE 8.15: THE PRINT PREVIEW WINDOW 
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6. Print Only If Details: 

As you can see in the preview, the report prints Salespersons and 
Customers but there are salespersons that do not have customers. To 
improve the report only salespersons that have customers have to be 
displayed. 

a. Open Report Dataset Designer for report 90000, Customer by 
Salesperson. 

b. Select the Salesperson data item 

c. Click View > Properties to open the Properties window 
d. Set the property PrintOnlyIfDetails to Yes. 
e. Save and close the report. 
f. Run it again from Object Designer to see the results. See “The 

Print Preview Window” figure for an example. 

 

FIGURE 8.16: THE PRINT PREVIEW WINDOW 

g. The report displays all salespersons, and displays the customers 
for each salesperson. Several fields, such as the Name field, are 
wide and require more space. These fields can grow to the 
second line. The CanGrow property defines this behavior. 
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7. Print Header on Every Page: 
The customers for some salespersons extend to more than one page. 
However, on the second page, the report does not print any headings 
that indicate which salesperson that the customers are associated 
with. The following steps show how to achieve this. 
a. Design report 90000, Customer by Salesperson, from the 

Object Designer.  
b. Click View, Layout.  
c. Open the Properties window for the table control, and select 

Repeat header rows on each page. See the “Tablix Properties” 
figure. 

 

FIGURE 8.17: TABLIX PROPERTIES 

d. Click OK to close the Properties window. 
e. Close Visual Studio, and then click Yes when you are prompted to 

save the changes.  
f. Click anywhere in Report Designer, and then click Yes to load the 

saved changes from Visual Studio.  
g. Compile, save and close the report.  

h. Run the report to view the changes. 
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8. Show New Record in a New Page: 

The following steps show how to start a new page for every 
Salesperson. 
a. Design report 90000, Customer by Salesperson, from the 

Object Designer.  
b. Click View, Layout.  
c. Open the Properties window for the row group.  
d. Click the Page Breaks tab.  
e. Select Between each instance of a group. 

f. Click OK to close the Group Properties window. 
g. Close Visual Studio, and then click Yes when you are prompted to 

save the changes.  
h. Click anywhere in the Report Dataset Designer, and then click Yes 

to load the saved changes from Visual Studio.  
i. Compile, save, and then close the report.  
j. Run the report to view the changes. 

The Request Page Designer 
The request page is displayed when the report is run. The request page lets the 
user provide additional input before previewing or printing the report. 

The Request Page Designer 

The request page is displayed when the report runs. When you create a new 
report, a request page is created automatically for the report. In addition, you can 
create custom options in the Request page. You design these options by using 
the Request Options Page Designer which is accessed from the Report Designer. 
The following steps show how to open the Request Options Page Designer. 

1. Open Report Designer from Object Designer. 
2. In Report Designer, click View, Request Page. 

The Request Options Page Designer resembles Page Designer. Here developers 
can add controls, such as FastTabs and fields to the request page. Controls that 
are created in the Request Options Page Designer always are displayed above the 
FastTabs that correspond to data items. 
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Design the Request Options Page 
The following demonstration shows how to do the following tasks: 

• Design the Request Options page. 

• Add and remove FastTabs from the Request Options page. 

• Add a control to the Options FastTab and use the control to affect the 
output of the report. 

Demonstration:  Add and Remove FastTabs on the Request 
Page 

Every data item has a FastTab on the request page. It can be hidden or shown by 
the property UseRequestPage. If UseRequestPage is No, then a request page is 
not shown. The user cannot select a sort order or set filters. 

Every data item has a FastTab on the Request page, although it can be hidden by 
setting certain properties. Currently the Customer by Salesperson report has two 
data items: the Salesperson/Purchaser data item, and the Customer data item.  

When it runs, the request page for this report shows the Salesperson tab.  

Demonstration Steps 

1. The following steps show how to add and remove tabs on the 
Request page.  
a. Design report 90000, Customer by Salesperson from the Object 

Designer.  
b. Open the Properties window for the Customer data item and 

clear the DataItemTableView property.  
c. Close the Properties window, and compile, save, and then run 

the report.  
 

2. The Request page now shows two tabs: the Salesperson and the 
Customer tabs.  
a. Close the Request page.  
b. Open the Properties window for the Customer data item and set 

the DataItemTableView property to SORTING("No.").  
c. Close the Properties window, and compile, save, and then run 

the report.  
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3. The Request page now shows only the Salesperson tab.  
a. Close the Request page.  

b. Open the Properties window for the Customer data item and set 
the ReqFilterFields property to "No.".  

c. Close the Properties window, and compile, save, and then run 
the report.  
 

4. The Request page now shows two tabs: the Salesperson and the 
Customer tabs.  
a. Close the Request page and close the report. 

Demonstration:  Create Options FastTab and Add a Check 
Box 

Demonstration Steps 

1. The following steps show how to create a check box in the Options 
FastTab of the Request page. 

a. Design report 90000, Customer by Salesperson, from Object 
Designer.  

b. Click View > C/AL Globals. The C/AL Globals window opens.  
c. Type the following in the Variables tab: 

Name DataType 

ShowDetails Boolean 

 
d. Close the C/AL Globals window. 
e. Click View > Request Page on the Toolbar. The Request 

Options Page Designer opens. It resembles Page Designer. See 
the “Request Options Page Designer” figure.  

f. Type the following on the first line of Page Designer: 

Name Caption Type SubType 

Request Page Request Page Container Content Area 

 
g. Go to the next blank line. The page elements automatically 

indent.  

h. Type the following: 

Name Caption Type SubType 

Options Options Group Group 

 

i. This creates the Options FastTab.  
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j. Type the following on the next line, and make sure that it is 
indented under the Options FastTab: 

Name Caption Type SourceExpr 

Show Details Show Details Field ShowDetails 

 

FIGURE 8.18: REQUEST OPTIONS PAGE DESIGNER 

 
k. Close Request Options Page Designer. 
l. Compile, save, and then close the report.  
m. Run the report in the RoleTailored client. 

 

FIGURE 8.19: THE REQUEST PAGE 
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The Request page now shows the following three FastTabs: 

• Options (displays Show Details check box) 

• Salesperson 

• Customer FastTabs  

Demonstration:  Skip Lines in a Report 

Use the value of the check box in the Request page to either display or not 
display a section in the report.  

Demonstration Steps 

1. The following steps show how to conditionally show the detail of the 
Customer, depending on the value of the Show Details check box in 
the Request page. 
a. Design report 90000, Customer by Salesperson, from Object 

Designer.  
b. Add a new line in Report Dataset Designer under the customer 

data item, and set the following properties:  

Data Type Data Source Name 

Column ShowDetails ShowDetails 

  
c. Click View, Layout.  
d. Select the third row (Detail) and set the following property:  

Visibility, Hidden: =IIF(Fields!ShowDetails.Value,false,true)  

e. Close Visual Studio, and then click Yes when you are prompted to 
save the changes.  

f. Click anywhere in Report Designer, and then click Yes to load 
the saved changes from Visual Studio.  

g. Compile, save, and then close the report.  
h. Run the report, select Show Details in the Options FastTab of the 

request page, and then click Preview.  
i. Close the report preview, rerun the report, and clear Show 

Details. 
j. Click Preview and view the changes. 
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Grouping and Totaling 
A report is usually designed to give the user summary information about what is 
in the database. This usually requires adding one or more fields that are displayed 
or read by the report, and then displaying the sum. This process is known as 
totaling the report. 

Microsoft Dynamics NAV uses subtotals and grand totals. Subtotals are shown 
after a logical grouping of records. Grand totals are shown at the end of the 
report. Subtotals sum the group and grand totals sum the whole report. This 
means, grand totals sum all subtotals. 

Demonstration:  Grouping 

The following demonstration shows how to create grouping in a report. For this 
demonstration, a new report is created. 

Demonstration Steps 

1. The following steps show how to create a new report that uses 
grouping. 

a. Create the Report Data Model. 
b. In Object Designer, click New. The Report Dataset Designer 

opens. 
c. Click the first empty line in Report Dataset Designer, and type 

or select the number or name of table 18, Customer in the 
DataItem column. The Name column is set to the table name by 
default. 

d. Click the next line, and add the table 21, Cust. Ledger Entry. 
e. Open the Properties window for the Customer Ledger Entry data 

item. 
f. Locate the DataItemLinkReference property, and verify that it is 

set to Customer. 
g. Locate the DataItemLink property, and then click the AssistEdit 

button on the DataItemLink property.  
h. The DataItem Link window opens. 

i. Type the following in the DataItem Link window: 

Customer No.=FIELD(No.) 

j. This links the Customer No. field from the Customer Ledger 
Entry  table to the No. field from the Customer table. 

k. Click OK to close the DataItem Link window. 
l. Compile and save the report by clicking File > Save As on the 

Toolbar. The Save As dialog box opens. 
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m. Type 90001 in the ID, and Customer Details in the Name. 
n. Make sure that Compiled is selected, and then click OK. This 

compiles and saves the report. 
 

2. Add columns to the dataset. 
a. In Report Dataset Designer, select the first line that contains the 

Salesperson/Purchaser data item. 
b. Click Field Menu to open the Field Menu window. 
c. In the Field Menu window, select the following fields: 

 No. 

 Name 

 City 

 Phone No. 
 

d. Click OK in the Field Menu window. 
e. Click Yes when you receive a confirmation message. The selected 

fields are added as columns in Report Dataset Designer, under 
the Customer data item. 

f. Repeat step a through e for the Customer Ledger Entry data 
item. Add the following fields to the Customer Ledger Entry data 
item: 

 Customer No. 

 Posting Date 

 Document Type 

 Document No. 

 Description 

 Amount (LCY) 

g. In the Report Dataset Designer toggle the Include Caption 
column for all the columns. The Report Dataset Designer now 
looks the “Customer Details Report Dataset” figure. 
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FIGURE 8.20: CUSTOMER DETAILS REPORT DATASET 

 
3. Create a Group on Posting Date and a group on Customer No. 

a. Click View, Layout.  
b. Microsoft Visual Studio Report Designer opens with a Dataset 

Result from the Report Dataset Designer. 
c. Drag a Table control from the toolbox to the Report layout. 
d. Right-click one of the columns, and then continue to click Insert 

Column to the Right, until the layout has a table with four 
columns. 

e. Drag the [@DocumentType_CustLedgerEntryCaption] from 
Parameters to the first column of the first table row.  

f. Use the caption fields for column headings instead of hard-coded 
text, to support a multilanguage scenario.  

g. Repeat Step e through f for the following fields from the 
Parameters to the appropriate columns of the first row of the 
table. You also can  go to each text box in the table and type the 
value property: 

 [@DocumentNo_CustLedgerEntryCaption]  

 [@Description_CustLedgerEntryCaption] 

 [@AmountLCY_CustLedgerEntryCaption]  
 

h. In the second row of the table, use the shortcut menu for each 
text box to add the following fields to the table: 

 [DocumentType_CustLedgerEntry] 

 [DocumentNo_CustLedgerEntry] 

 [Description_CustLedgerEntry] 

 [AmountLCY_CustLedgerEntry] 
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i. In the Grouping panel at the bottom of the screen, click the Row 
Group arrow, and then select: Add Group, Parent Group. 

j. In the Group By drop-down list box, select 
[PostingDate_CustLedgerEntry]. 

k. Select Add group Footer. 
l. Click OK. 

m. In the first field of the first row, change the value to the following: 
[@PostingDate_CustLedgerEntryCaption]. 

n. In the Row Groups panel, select Group 1 Properties. The Group 
properties window opens.  

o. Change the Name of the group from Group 1 to PostingDate. 
p. In the Grouping panel at the bottom of the screen, click the Row 

Group arrow of the PostingDate group, and then select Add 
Group, Parent Group. 

q. In the Group By field, select: [No_Customer]. 
r. Select Add group Footer. 
s. Click OK. 
t. In the first field of the first row, change the value to the following: 

[@No_CustomerCaption]. 
u. In the Row Groups panel, select Group 1 Properties. The Group 

Properties window opens.  

v. Change the Name of the group from Group 1 to Customer. 
w. Right-click the column header of the first text box on the table 

header, and then select: Insert Column, Inside Group – Right. 
x. Repeat step w twice. See the “Tablix with Two Groups” figure. 

y. On the first (header) row, in the newly added columns, set the 
value to the following: 

 [@Name_CustomerCaption] 

 [@City_CustomerCaption] 

 [@PhoneNo_CustomerCaption] 
 

z. On the second row, in the newly added columns, use the shortcut 
menu to set the values for the text boxes to the following: 

 [Name_Customer] 

 [City_Customer] 

 [PhoneNo_Customer] 
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FIGURE 8.21: TABLIX WITH TWO GROUPS 

 
4. Run the report. 

a. When you run the report it now looks like the “Preview Report” 
figure.  

 

FIGURE 8.22: PREVIEW REPORT 
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Demonstration:  Totaling 

The following demonstration shows how to add totals to the report. 

Demonstration Steps 

1. Add Labels to the Report Dataset. 
a. In the Report Dataset Designer, select View > Labels from the 

Toolbar. The Report Label Designer window opens. 
b. Add the following three labels: 

Name Caption 

TotalPostingDate Total for Posting Date 

TotalCustomer Total for Customer 

GrandTotal Grand Total 

 
2. Add Totals in the report. 

a. Click View > Layout to open Visual Studio Report Designer. 
b. In the Amount column, in the third and fourth row, enter the 

following expression for the value: 

=Sum(Fields!AmountLCY_CustLedgerEntry.Value) 

 
3. Merge cells. 

a. In the seventh and eighth columns, on the third and fourth rows, 
merge the text boxes of the two columns by doing the following: 

 Select the text boxes that you want to merge. 

 Right-click and then select Merge Cells. 
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FIGURE 8.23: MERGE CELLS OPTION 

 
b. In the merged cell on the third row, type the following expression 

for the value: 

=Parameters!TotalPostingDate.Value & " " & 
Fields!PostingDate_CustLedgerEntry.Value 

c. In the merged cell on the fifth row, type the following expression 
for the value: 

=Parameters!TotalCustomer.Value & " " & Fields!No_Customer.Value 
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d. In the Row Groups panel at the bottom of the screen, click 

Customer group, and then select Add Total, After: A new row is 
added to the bottom of the table. This row displays Grand Totals. 
See the “Add Total After” figure. 

 

FIGURE 8.24: ADD TOTAL AFTER 

 
e. Merge the cells of the seventh and eight columns of the last row. 
f. In the merged text boxes, type the following expression in the 

value of the text box: 

=Parameters!GrandTotal.Value 

4. Format the report. 
a. Select the last column of the table by clicking the column handle. 
b. In the Property list, for the Format property, enter the following 

expression:  

=Fields!AmountLCY_CustLedgerEntryFormat.Value 

c. Select the text boxes that contain the totals and set FontWeight 
to Bold. 

d. Select the first row of the table and set FontWeight to Bold. 
e. Select the text box that contains the Posting Date, and then set 

the Format property to dd/MM/yyyy. 

f. Set the Width for the column that contains the Description to 
5,3cm. 

g. Select the last four columns and set TextAlign to Right. 
h. Select the table and set the FontSize to 9pt. 

 
5. Run the report. 

a. Save the changes in Visual Studio and in the Report Dataset 
Designer. 

b. When you run the report, it should looks like the “Report 
Preview” figure. 
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FIGURE 8.25: REPORT PREVIEW 

Add Advanced Features 
The following demonstration shows how to add advanced features to the report, 
such as FlowFilters. The demonstration also features specific functionality in 
Report Viewer, such as interactive sorting, hide/collapse, and charts. 

Demonstration:  Using FlowFilters 

The following steps show how to filter a report that uses the Date Filter field in 
the Customer table. 

Demonstration Steps 

1. Add a Flowfilter field. 
a. Design report 90001, Customer Detail, from the Object 

Designer. 
b. Open the Properties window for the Customer data item, and set 

the ReqFilterFields property to include the Date Filter field. See 
the “REQFILTERFIELDS on the Customer Properties” figure. 
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FIGURE 8.26: REQFILTERFIELDS ON THE CUSTOMER PROPERTIES 

 
c. Open the Properties window for the Cust. Ledger Entry data 

item, and set the DataItemLink property to the following:  

Customer No.=FIELD(No.),Posting Date=FIELD(Date Filter). 

See the “DATAITEMLINK” figure. 

 

FIGURE 8.27: DATAITEMLINK 

d. Close the Properties window and then compile, save, and close 
the report. 

e. Run the report. 
f. In the Customer tab of the request form, type the range 

01/01/01..12/31/01 in the Filter column for the Date Filter field, 
and then click Preview. 

g. Check whether there are any records outside the range that is set. 
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Demonstration:  Adding Interactive Sorting 

The following steps show how to add interactive sorting to the Customer by 
Salesperson report. 

Demonstration Steps 

1. Add Interactive Sorting. 
a. Design report 90000, Customer by Salesperson, from Object 

Designer. 

b. Click View > Layout from the Toolbar. 
c. Select the text box in the first column of the table header row 

[@Code_SalespersonPurchaserCaption] and set the following 
properties: 

• UserSort, SortExpression: =Fields!Code_SalespersonPurchaser.Value 

• UserSort, SortExpressionScope: table1_Group1 

See the “Usersort Properties” figure. 

 

FIGURE 8.28: USERSORT PROPERTIES 

 
d. Repeat Step c for the remaining text boxes in the table header 

row with their respective SortExpression.  Leave the 
SortExpressionScope property blank for text boxes that belong 
to Customer table.  

e. Close Visual Studio, and then click Yes when you are prompted to 
save the changes.  

f. Click anywhere in Report Designer, and then click Yes to load 
the saved changes from Visual Studio. 

g. Compile, save, and close the report.  
h. Run the report in the roletailored client to view the changes. See 

the “Report with Interactive Sorting” figure.  
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FIGURE 8.29: THE REPORT WITH INTERACTIVE SORTING 

Demonstration:  Adding Hide/Collapse 

The following demonstration shows how to add the hide/collapse feature to the 
Customer by Salesperson report. 

Demonstration Steps 

1. Add Hide/Collapse. 
a. Design report 90000, Customer by Salesperson, from Object 

Designer. 
b. Click View > Layout. 
c. Select the first group detail row (third row), and then set the 

following property: Visibility, ToggleItem: 
Code_SalespersonPurchaser. 

d. Select the text box in the first column, second row 
(Salesperson_Purchaser_Code), and then set the following 
property: InitialToggleState: True.  

e. Close Visual Studio, and then click Yes when you are prompted 
to save the changes. 

f. Click anywhere in Report Designer, and then click Yes to load 
the saved changes from Visual Studio. 

g. Compile, save, and close the report. 
h. Run the report in the RoleTailored client to view the changes. See 

the “Report with Hide/Collapse” figure. 
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FIGURE 8.30: THE REPORT WITH HIDE/COLLAPSE 

Demonstration:  Adding a Chart 

Charts are a graphical representation of data, and help present information in a 
summarized, yet concise manner. The following steps show how to add a chart to 
the Customer by Salesperson report to represent the number of customers that 
a salesperson has. 

Demonstration Steps 

1. Add a Chart. 
a. Design report 90000, Customer by Salesperson, from Object 

Designer. 
b. Click View > Layout on the Toolbar. 
c. Drag a Chart control from the toolbox to the report layout. 
d. The Select Chart Type window opens.  

e. Select the shape that is indicated on Add a Pie Chart. See the 
“Select Chart Type” figure. 
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FIGURE 8.31: SELECT CHART TYPE WINDOW 

 
f. Click OK. 
g. Right-click the title of the chart, and then select Title properties. 

In the Chart Title Properties window that opens, in the Title 
text text box,  type “Customer by Salesperson” as shown in the 
“Chart Title Properties” figure. 

 

FIGURE 8.32: CHART TITLE PROPERTIES 
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h. Click OK. 

i. Drag the field No_Customer from the dataset to the Drop data 
fields here area. 

j. Right-click the added field and select: Series Properties. 
k. In the Series Properties window, set the Value field to the 

following: [Count(No_Customer)] as shown in the “Series 
Properties” figure. 

 

FIGURE 8.33: SERIES PROPERTIES 

 
l. Click OK. 
m. In the Drop series fields here area, select the 

Code_SalespersonPurchaser field as shown in the “Series Fields” 
figure. 

 

FIGURE 8.34: SERIES FIELDS 

 

n. Close Visual Studio, and then click Yes when you are prompted to 
save the changes. 

o. Click anywhere in Report Designer, and then click Yes to load 
the saved changes from Visual Studio.  

p. Compile, save, and then close the report.  
q. Run the report in the RoleTailored client to view the changes. See 

the “Report with a Chart” figure. 

Microsoft Official Training Materials for Microsoft Dynamics ® 
Your use of this content is subject to your current services agreement 

 



C/SIDE Introduction in Microsoft Dynamics® NAV 2013 

8 - 42 

 

FIGURE 8.35: THE REPORT WITH A CHART 
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Lab 8.1: Creating a Basic Report 
Scenario 

Simon is a developer working for CRONUS International Ltd. CRONUS 
International has decided to sell Microsoft Dynamics NAV training courses as its 
business. 

Simon has already created a Course table to record course information. Now, 
Simon must create a report to list all available courses. 

Objectives 

The following lab tests basic knowledge about how to create a report in Microsoft 
Dynamics NAV 2013. 

Exercise 1: Build the report. 
Exercise Scenario 

1. Create a report that has the following requirements:  

a. Prints all course information.  
b. Filters by course type.  

 
2. Create this report to run with the following advanced features:  

a. Interactive sorting.  
b. A bar chart that represents courses and the cost of investment 

(price) for each course.  

Task 1: Create a new report. 

High Level Steps 
1. Create the dataset. 

Detailed Steps 
1. Create the dataset. 

a. In Object Designer, click New.  

b. In the Report Dataset Designer, set the Course table as a data 
item. 

c. Use the Field Menu to add all fields from the course table to the 
dataset as columns. 

d. Make sure that all fields have Include Caption.  
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Task 2: Add a filter 

High Level Steps 
1. Add a filter to the report dataset. 

Detailed Steps 
1. Add a filter to the report dataset. 

a. Open the Properties window for the course data item.  
b. Set the ReqFilterFields property to Type.  

c. Close the Properties window. 

Task 3: Create a Layout 

High Level Steps 
1. Create a layout for the report. 

Detailed Steps 
1. Create a layout for the report. 

a. Click View > Layout.  
b. Drag a Table control from the toolbox to the report layout.  
c. Click one of the columns, right-click, and then click Insert 

Column to the Right.  
 Repeat the step to add five columns.  

 

d. Type the following parameters in the appropriate columns of the 
first row of the table:  

 [@Code_CourseCaption] 

 [@Name_CourseCaption] 

 [@Description_CourseCaption] 

 [@Type_CourseCaption] 

 [@Duration_CourseCaption] 

 [@Price_CourseCaption] 

 [@Active_CourseCaption] 

 [@Difficulty_CourseCaption] 
[@PassingRate_CourseCaption]  
 

e. Set the following DataSet Result fields as the expression by 
typing them in the appropriate columns of the second row of the 
table:  

 Code_Course 

 Name_Course 

 Description_Course 
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 Type_Course 

 Duration_Course 

 Price_Course 

 Active_Course 

 Difficulty_Course 

 Passing_Rate_Course  

Task 4: Adding Interactive Sorting 

High Level Steps 
1. Add interactive sorting to the table. 

Detailed Steps 
1. Add interactive sorting to the table. 

a. Select the [@Code_CourseCaption text box in the first column of 
the table header row],  and set the following properties:  

UserSort, SortExpression:  

=Fields!Code_Course.Value 

 Repeat the step for the remaining text boxes in the table 
header row with their respective SortExpression. 

Task 5: Add a Chart 

High Level Steps 
1. Add a Chart to the Report. 

Detailed Steps 
1. Add a Chart to the Report. 

a. Drag a Chart control from the toolbox to the Report layout.  
b. Select the chart control. 
c. Set the following:  

i. Title: Course Price  
ii. Chart Type: Bar 

 
d. In the Drop data fields, set the following:  

[Sum(Price_Course)] 

e. In the Drop series fields, set the following: 

[Code_Course] 
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f. As a series Label use the following:  

[Name_Course] 

 
g. Close Visual Studio, and then click Yes when you are prompted to 

save the changes.  
h. Click anywhere in Report Designer, and then click Yes to load the 

saved changes from Visual Studio.  
i. Compile and save the report as 90011, Course List and then 

close the report. 
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Module Review 
Module Review and Takeaways 

An organization's ability to collect dependable, timely business intelligence is 
fundamental to its health. Reports are a way to obtain that intelligence. A C/SIDE 
developer must create robust reports on demand. This involves understanding not 
only the mechanics of report creation, but also business needs.  

Reports can print information from a database, and structure and summarize 
information. Use reports to print documents such as invoices. You can also use 
reports to process data without printing. 

Creating reports includes designing both the business logic that covers the kind of 
information that the report contains, and the layout that determines the look of 
the printed report.  

Test Your Knowledge 

Test your knowledge with the following questions. 

1. How is the dataset defined in a report in Dynamics NAV 2013? 

(   ) You use Report DataItem Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(   ) You use Report Dataset Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(   ) You use Report Column Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(   ) You use Report Property DatasetFieldname in Microsoft Dynamics 
NAV Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

2. Which of the following answers cannot be used as a Column in a Data Item? 

(   ) A field in a table. 

(   ) A variable 

(   ) A property of a table. 
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(   ) An expression 

(   ) A caption that is not related to a specific table 

3. How can you define a master/detail relationship between tables in the Report 
Dataset Designer? 

(   ) The indented data item has the DataItemLinkReference property and 
the DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 

(   ) Each data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 

(   ) Each data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the child 
data item to link to (the data item must be indented under the parent 
data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the child data item in the DataItemLinkReference property. 

(   ) The parent data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 
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4. The Report Definition Language (RDL) Data is a report component that is used 
by Microsoft Dynamics NAV to display the report in the RoleTailored client. 
Microsoft Visual Studio Report Designer is an external designer that is used to 
design the visual element (the RDL data) of a report. It is accessed from the 
Report Dataset Designer. 

(   ) True 

(   ) False 

5. How do you create a Request Page for a new report? 

(   ) When you create a new report, a request page is created 
automatically for the report. This request page cannot be edited, 
except by using a special license. 

(   ) When you create a new report, you need to create a separate page 
object and link it to the report object for it to become the request 
page. In addition, you can create custom options in the Request page. 
You design these options by using the Page Designer which is 
accessed from the Object Designer. 

(   ) When you create a new report, a request page is created 
automatically for the report. In addition, you can create custom 
options in the Request page. You design these options by using the 
Request Options Page Designer which is accessed from the Report 
Designer. 

(   ) When you create a new report, a request page is created 
automatically for the report. In addition, you can create custom query 
options in the Request page. You design these options by using the 
Query Designer which is accessed from the Object Designer. 

6. Which properties in Visual Studio Report Designer are used to add a 
hide/collapse feature to a report? 

(   ) Visibility, ToggleItem 

(   ) Hidden, ToggleItem 

(   ) Visible, ToggleItem 

(   ) Visibility, ItemToggle 

(   ) Hidden, ItemToggle 
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7. How can you add a flowfilter field to a report? 

(   ) Flowfilter fields cannot be added to reports in Dynamics NAV 2013. 

(   ) Flowfilter fields are added automatically to a report after you select a 
Data Item. 

(   ) Open the Properties window for the Data Item, and set the 
ReqFilterFields property to include the FlowFilter field. 

(   ) Open the Properties window for the Data Item, and set the 
FlowFilterFields property to include the FlowFilter field. 
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Test Your Knowledge Solutions 

Module Review and Takeaways 

1. How is the dataset defined in a report in Dynamics NAV 2013? 

(   ) You use Report DataItem Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(√) You use Report Dataset Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(   ) You use Report Column Designer in Microsoft Dynamics NAV 
Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

(   ) You use Report Property DatasetFieldname in Microsoft Dynamics 
NAV Development Environment to define the dataset of a report. You 
build the report dataset from data items and columns. 

2. Which of the following answers cannot be used as a Column in a Data Item? 

(   ) A field in a table. 

(   ) A variable 

(√) A property of a table. 

(   ) An expression 

(   ) A caption that is not related to a specific table 

3. How can you define a master/detail relationship between tables in the Report 
Dataset Designer? 

(   ) The indented data item has the DataItemLinkReference property and 
the DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 
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(√) Each data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 

(   ) Each data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the child 
data item to link to (the data item must be indented under the parent 
data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the child data item in the DataItemLinkReference property. 

(   ) The parent data item has the DataItemLinkReference property and the 
DataItemLink property. These properties define a Master/Detail 
relationship between two tables. 
In the DataItemLinkReference property of a data item, select the 
parent data item to link to (the data item must be indented under the 
parent data item). 
In the DataItemLink property of the indented data item, specify a 
filter for this data item by matching fields in this data item with fields 
from the parent data item in the DataItemLinkReference property. 

4. The Report Definition Language (RDL) Data is a report component that is used 
by Microsoft Dynamics NAV to display the report in the RoleTailored client. 
Microsoft Visual Studio Report Designer is an external designer that is used to 
design the visual element (the RDL data) of a report. It is accessed from the 
Report Dataset Designer. 

(√) True 

(   ) False 

5. How do you create a Request Page for a new report? 

(   ) When you create a new report, a request page is created 
automatically for the report. This request page cannot be edited, 
except by using a special license. 
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(   ) When you create a new report, you need to create a separate page 
object and link it to the report object for it to become the request 
page. In addition, you can create custom options in the Request page. 
You design these options by using the Page Designer which is 
accessed from the Object Designer. 

(√) When you create a new report, a request page is created automatically 
for the report. In addition, you can create custom options in the 
Request page. You design these options by using the Request Options 
Page Designer which is accessed from the Report Designer. 

(   ) When you create a new report, a request page is created 
automatically for the report. In addition, you can create custom query 
options in the Request page. You design these options by using the 
Query Designer which is accessed from the Object Designer. 

6. Which properties in Visual Studio Report Designer are used to add a 
hide/collapse feature to a report? 

(√) Visibility, ToggleItem 

(   ) Hidden, ToggleItem 

(   ) Visible, ToggleItem 

(   ) Visibility, ItemToggle 

(   ) Hidden, ItemToggle 

7. How can you add a flowfilter field to a report? 

(   ) Flowfilter fields cannot be added to reports in Dynamics NAV 2013. 

(   ) Flowfilter fields are added automatically to a report after you select a 
Data Item. 

(√) Open the Properties window for the Data Item, and set the 
ReqFilterFields property to include the FlowFilter field. 

(   ) Open the Properties window for the Data Item, and set the 
FlowFilterFields property to include the FlowFilter field. 
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